problemas XML y ML

Mapa del Sitio

 problemas XML y ML

problemas XML y ML [16-01 13:36] por JACUNA2003 [arg]
Gente, para mi está totalmente imposible desde el viernes el tema del XML e incluso entrar a este portal de PMS... alguien está experimentando el mis problema? A mi el XML me está tirando el servidor abajo, está lentísimo y también está muy lentro entrar al portal PMS...

[16-01 16:04] por HEROEALBICELESTE [arg]
el tema no es XML en si... si no la cantidad de consultas que debe tener... quizas habria que mejorar el hard... aveces entras a tu sitio y carga rapidisimo, y a los 10 minutos tarda media hora... sacas XML y carga al toque... entonces lo unico que me deja pensar es que cuando carga rapidisimo es que el server (o los...) estan recien reseteados con memoria libre...

[16-01 16:18] por JACUNA2003 [arg]
mira... casi te diria que definitivamente es el XML en conjunto con la bosta de ASP y Microsoft. El XML a veces tiene demasiados tiempos y eso embota al ASP de nuestro amigo Gates... saqué la totalidad de las consultas XML y mi sitio vuela...

[16-01 19:55] por HEROEALBICELESTE [arg]
No se como parsea el codigo XML ASP, pero en PHP existe un parametro que hace /"ignorar/" los errores y posibles /"breaks/" en el codigo, ej:
@tu_xml_parse();
Si pones la arroba (en php, obviamente) este simplemente ignorará los problemas de XML (o de cualquier funcion a la que se lo pongas) y asi cargará el sitio normalmente (sin dicha funcion).

[16-01 23:38] por ARESNET [arg]
Sin embargo, no es buena práctica cargar todo con errores ocultos, ya que es lo mismo que nada.
Más vale usar IF-ELSE para no hacer cagadas y dejar al visitante viendo una página en blanco sin explicación de porqué el contenido solicitado no aparece.
Saludos,
Leo

[17-01 05:45] por HEROEALBICELESTE [arg]
Todo lo contrario, si tu anulas los breaks que probocan los mensajes de error el resto de la pagina cargara perfectamente (ahora si tu basas TODO tu sitio en los XML de ML es otro problema). Ademas de que el usuario final no tiene que ver ningun error interno (para que darle informacion que no necesita?), eso se evita con las arrobas, no en todos lados, si no en funciones que las necesiten.
Mi /"shop/" tiene 2 tiendas, una se maneja con ML y la otra no, entonces cuando XML de ML se cae se puede navegar perfectamente por la otra mitad sin estar viendo mensajes que, para quien no sabe, parecen chino mandarín...

pffffffff [17-01 14:17] por ARESNET [arg]
Ojo, que no dije no es buena práctica usar @ , sino que no es buena práctica anular todos los errores y no hacer nada si ocurre un error. El @ no hace magia ni arregla los errores, solamente los oculta.
Porque si bien uno anula errores (ya que no es bueno mostrar los directorios internos e información importante (como de MySQL)), es muy importante saber cuándo esos errores pueden arrastrarse por toda la página y distorcionar el contenido.
A eso me refiero cuando hablo de un IF-ELSE. Ya que arrastrar errores o no mostrar su debida explicación (a nadie le interesa saber que se cayó un servidor, sino un pequeño no disponible en este momento ), es como si los mostraras...
Y si bien no todos son tontos, es importante decirlo, porque otros, que recién se inician pueden pensar bueno, anulo los errores y listo , pero termina siendo contraproducente. Por eso, anular es bueno, pero con su debido orden y condiciones para que la página sea navegable.
Saludos,
Leo

... [16-01 16:15] por LUIGIKIKE [arg]
Como andás de carga de servidor? en promedio diario, por ejemplo.
Uso de memoria?
Quizás el server te quedó chico.
Saludos,

[16-01 16:20] por JACUNA2003 [arg]
es el XML... pasa que hago (o hacia) un uso bastante intenso del XML. Para que te des idea, cualquier busqueda que se hace en mi sitio la hacia tambien en XML a ver si encontraba algo. Ahora eliminé todo el XML y anda todo perfecto. para mi el problema está entre ML, IPLAN (mi bosta proveedor) y ASP (la bosta de Microsoft). Tengo algo así como unos 5K usuarios unicos por dia en primedio que se duplican cuando el shop de ML anda bien (y no es el caso ahora).

... [16-01 16:27] por LUIGIKIKE [arg]
Me animo a decir que ML anda bien, sobre asp conozco poco así que no puedo opinar.
Es la basura de Iplan! yo a esta altura en el 2005 estaba en un servidor con conexión iplan y se demoraba horrores en descargar las páginas con xml.
Como siempre digo, para trabajar con feeds xml de ML lo mejor es usar un server con conexión yankie, la velocidad mejora muchísimo, la conexión argentina es terrorífica.
Saludos,

[16-01 16:34] por JACUNA2003 [arg]
vos sos BOONIC?

... [16-01 22:33] por LUIGIKIKE [arg]
Hola Jacuna!
yes, cierto que vos t pasaste casi al mismo tiempo q yo a un server en USA.
Saludos,

[16-01 22:40] por JACUNA2003 [arg]
si! y te agradezco porque anda muy bien. Estoy terminando de pasar todos mis sitios al nuevo server. Y cómo te funcionó el tema de las visitas restringidas para argentina en google? porque vi que en algunos casos estas bien posicionado ;) pero tenés el dominio .com... notás algún cambio?

[16-01 16:34] por JACUNA2003 [arg]
ya hace varios meses que tengo a mi server en USA con otros sitios que también trabajan con ML, pero no paso este sitio que es el que más movimiento me da porque el dominio es .com y pierdo las visitas de argentina de google... pero la verdad que a esta altura no se qué es mejor :P

igual [16-01 23:00] por OSCARVA1 [col] [arg]
yo para entrar siempre tengo probelmas, tengo que ingresar varias veces el pass refrescar la pagina como 20 veces y tarda como 20 min en abrir
Hace mucho timepo que lo noto este problema

[16-01 14:09] por JACUNA2003 [arg]
sep... pero desde este viernes el XML está una lágrima... y hoy lo estoy comprobando... estoy anulando todas las consultas XML y veo que ahora mi sitio vuela...

Gracias por visitar el foro de " problemas XML y ML".
Búsqueda personalizada

@ empremexico Derechos Reservados 2017 - Empresas de México

Políticas de Privacidad  - Términos y Condiciones - Noticias - Contacto