Nuevo portal y consulta XML

Mapa del Sitio

 Nuevo portal y consulta XML

Nuevo portal y consulta XML [22-10 14:07] por HEROEALBICELESTE [arg]
Hola gente:
Les cuento que rediseñe totalmente mi portalito y quería saber que opinaban: http://www.my-shop.com.ar/
Cualquier consejo/sugerencia será bien recibido.
Por otra parte, quisiera saber si hay alguna forma de /"paginar/" los resultados de XML, he visto que SearchXML tiene los siguientes parámetros:
<listing items_from=/"1/" items_to=/"10/" items_total=/"59/" order_by=/"más ofertados/">
Mi consulta es, como puedo hacer desde mi pagina para indicarle que /"items_from/" no es 1 sino, por ejemplo, 10... para paginar de 10 en 10 los articulos??
Intente pasando el parámetro por GET pero no va...
Espero me ayuden.

en el xml [23-10 01:18] por VIVARACHO [arg]
Tenes esta parte:
&as_desde=1&as_qshow=50
El 50 (suponiendo que mostras 50, queda siempre igual), pero cambia el as_desde=1 por as_desde=51 por ejemplo.
Si queres podes poner:
as_desde=$desde (siendo $desde el valor que le pases por GET o por POST)
Espero que te sirva.
Saludos!

[23-10 01:33] por HEROEALBICELESTE [arg]
VIVARACHO, ahora lo voy a probar... yo estaba probando pasarle /"item_from/" :p
Me parecia raro que no tuviera este parametro, pero no queria joder a Martin por mail otra vez (ya le mande varios en la semana)...
Te agradezco.

jajaja [23-10 01:36] por VIVARACHO [arg]
oka....mandale no mas...que le pagan para eso!!!
jajajaja, era chiste martin eh....no te enojes!


:) [24-10 09:47] por MARTIN ML [arg]
Hola HERO!
Mandame todos los mails que sean necesarios :)
Saludos,
M

[23-10 02:53] por HEROEALBICELESTE [arg]
VIVARACHO, funciona, el tema es que tengo un problema...
No se porque razon solo me deja pagina 6 paginas (valga la redundancia) con 15 resultados cada una... es decir, me deja paginar hasta que as_desde es = a 90 (aprox)... no se cual es la razon...
Haciendo pruebas directamente en el XML de ML me di cuenta de que cuando as_desde es mayor o igual a 100 comienzan los problemas...
Por ejemplo, si pongo as_desde=240, en el listado XML solo me aparecen los datos de la categoria (filtros, etc) pero no los articulos...
Si tenes idea de como solucionarlo...

si no me equivoco... [23-10 13:07] por VIVARACHO [arg]
Es un tema de permisos que tu user y pass.
Ahi tenes que hablar con martin o fede y preguntarles cuantos articulos podes listar con tu user y si te pueden dar mas.
Cualquier cosa decime.
Saludos!

[23-10 20:34] por HEROEALBICELESTE [arg]
Esos datos ya los tengo...
Tu has podido paginar resultados arriba de 100?
Por el momento lo que hice fue paginar solo hasta que as_desde sea <= 99...

si... [23-10 22:02] por VIVARACHO [arg]
Hasta 500 tengo yo.
Por eso te digo que ese tema lo consultes con martin.
Saludos!

[24-10 13:47] por HEROEALBICELESTE [arg]
Hola viva...
Tenías razon, es un tema de permisos, yo tengo solo hasta 100 articulos.
Igualmente lo dejo así hasta que tenga más trafico el sitio, luego aumento la cantidad y listo ;)
Saludos y gracias por todo.

Gracias por visitar el foro de " Nuevo portal y consulta XML".
Búsqueda personalizada

@ empremexico Derechos Reservados 2017 - Empresas de México

Políticas de Privacidad  - Términos y Condiciones - Noticias - Contacto